PHP-Fusion Sverige » PHP-Fusion 7.* » Innehåll
 Skriv ut debatt
åäö funkar ej?
Bonnis
Installerade php fusion o även swedish locale, men åäö funkar ej.
hur fixar ja det problemet?

site: www.bananparty.se
 
Homdax
Det kan vara så att i databasservern kan du vara tvungen att ange att siten och databasen skall köra "CollationLatin1" så att den tolkar alla uttryck rätt.

http://stackoverf...swedish-ci
 
Bonnis
hm, allt står på "latin1_swedish_ci"?
 
Bonnis
tror de e nått med senaste php fusion ja, är även så här på webhotell som de alltid har funkat på mm.
 
Homdax
Jag har haft strul med det i samband med en uppgradering av denna site så jag sticker inte under stol med att det kan klydda, skall se om jag får tag i DrunkeN...
 
Bonnis
grymt, hade varit fett att få detta fixat :)
 
DrunkeN
Tja. Hittade följande länk efter lite googlande och jag har inte testat. Hade samma problem vid en uppgradering för ett par år sedan men kommer tyvärr inte ihåg vart jag skrev om det men jag fick ordning på det.


http://elektronik...mp;t=68455

Vet inte vad som händer om man sätter in följande kod i Administrations Panel > Användarsidor/Custom Pages och klicka bara Preview/Förhandsgranska knappen

Källa  Kod
 
<?php
global $db_name;
mysql_select_db($db_name) or die ("Ingen databas!");
mysql_set_charset('utf8');
?>





EDIT: Är sidan ny installerad? eller har du uppgraderat från en tidigare version till nyare? Isådana fall är det nog inget med mysql då texten

Anv&#65533;ndarnamn och L&#65533;senord: har inget med mysql och göra utan det är såna fall något i headern. Ska kolla runt lite

EDIT: Du kan ju testa ändra charset till utf-8 genom att öppna

locale/global.php hitta
Källa  Kod
$locale['charset'] = "iso-8859-1";




ersätt med
Källa  Kod
$locale['charset'] = "utf-8";



Redigerat av DrunkeN den januari 13 2015 01:17:38
Dark-Fusion SE
"Bättre att vara långsam och noggrann än att ha bråttom och slarva"
 
Bonnis
DrunkeN skrev:

Tja. Hittade följande länk efter lite googlande och jag har inte testat. Hade samma problem vid en uppgradering för ett par år sedan men kommer tyvärr inte ihåg vart jag skrev om det men jag fick ordning på det.


http://elektronik...mp;t=68455

Vet inte vad som händer om man sätter in följande kod i Administrations Panel > Användarsidor/Custom Pages och klicka bara Preview/Förhandsgranska knappen

Källa  Kod
 
<?php
global $db_name;
mysql_select_db($db_name) or die ("Ingen databas!");
mysql_set_charset('utf8');
?>





EDIT: Är sidan ny installerad? eller har du uppgraderat från en tidigare version till nyare? Isådana fall är det nog inget med mysql då texten

Anv&#65533;ndarnamn och L&#65533;senord: har inget med mysql och göra utan det är såna fall något i headern. Ska kolla runt lite

EDIT: Du kan ju testa ändra charset till utf-8 genom att öppna

locale/global.php hitta
Källa  Kod
$locale['charset'] = "iso-8859-1";




ersätt med
Källa  Kod
$locale['charset'] = "utf-8";




testat både sakerna nu, utan resultat.
och ja sidan är helt nyinstallerad med nyaste versionerna.

hade varit kul o se om nån annan här kan testa installera en ny på sidan av, fråga en vän som har en annan host han hade samma problem.
 
Homdax
Njae, det är en sak jag tror behöver ett förtydligande.

Först och främst så installerar du fusion, installationen bör normalt ske på engelska, sedan tankar du upp de språkfiler vi har och lägger in som en mapp i /locale/ När det är gjort dyker svenska upp som ett alternativ i språklistan och då byter du språk.

För uppgraderingar och vidare anpassningar har jag alltid sagt att man bör växla över till Engelska, för det är det mest kompletta språket, de andra är bara typ 99% i jämförelse, alltid någon konstig formulering.

Så, varifrån har du hämtat fusion, och varifrån har du hämtat språkfilerna, om vi börjar där?

Bara som bevis: http://www.rikard... ... uppe relativt nyligen, fusion på svenska. Exakt som jag skrivit ovan. (jag).
Redigerat av Falk den januari 13 2015 20:04:48
 
Homdax
ytterligare bevis:

i.imgur.com/fht1q01.jpg
 
Bonnis
Ja installera fusion på engelska o de, sedan la in språket, men ja kan väl testa igen antar ja o.O
 
Bonnis
Funka inte!

Installera PHP fusion genom att ladda ner de på sidan. satt 777 som man ska för vissa filer, anger databas mm

laddar upp svenska språket som ja laddar ner här ifrån.

väljer svenska in main settings.

funkar ej! :(
 
Bonnis
kan notera att ja rensa allt, databasen o rubbet innan installation
 
Homdax
Vilken host?

Vill du att jag skall testa? (Då behöver jag dina åtkomster, skicka via PM). Du kan alltid byta lösenorden senare.
 
Bonnis
Richard Ainz skrev:

Vilken host?

Vill du att jag skall testa? (Då behöver jag dina åtkomster, skicka via PM). Du kan alltid byta lösenorden senare.


One.com

Ja skickar åtkomst :)
 
Homdax
OK, gammal bekant, vi hade denna site på One tills för några månader sedan. Aldrig några allvarliga problem annat än att den kunde vara ite slö.
 
Bonnis
Richard Ainz skrev:

OK, gammal bekant, vi hade denna site på One tills för några månader sedan. Aldrig några allvarliga problem annat än att den kunde vara ite slö.


ja har installerat php fusion flera gånger alltså,
detta har aldrig hänt!

har du lust att testa installera om du finner tid? :)
 
Homdax
var inne i min databas på One (den försvinner om några dagar) och det ser faktiskt ut så här:

Alltså UTF-8 i Generella inställningar.

Däremot så är collation för alla VARCHAR och TEXT fält: latin1_swedish_ci
Homdax bifogade följande bild:bild:
scr36.png
 
Bonnis
Richard Ainz skrev:

var inne i min databas på One (den försvinner om några dagar) och det ser faktiskt ut så här:

Alltså UTF-8 i Generella inställningar.

Däremot så är collation för alla VARCHAR och TEXT fält: latin1_swedish_ci


Stog samma för mig?
 
Homdax
har dragit en tråd på Uk så får de skarpa hjärnorna där kika.... https://www.php-f...ost_192933
 
Gå direkt till forum: