Skriv ut ämne
Gamla sajter p? 6.01.19 funkar inte d? safemode=off
etxgmg
Hej, Mitt webbhotell (Surftown) har pl?tsligt tagit bort safemode och d? funkar inte l?ngre PHP-Fusion version 6.01.19 sajternas fotoalbum (2 st olika) som jag moddat f?r att passa kundernas behov (lite halvkommersiella sajter, hobby- och f?reningsaktivitet, med f?rs?ljning av alster). Just fotoalbumfunktion ?r den som ?r absolut viktigast p? dessa tv? sajter.

Sajterna ?r s? mycket moddade i tema och fotoalbum (iofs bara bortkommenterad kod i photogallery.php) att det nog inte ?r n?gon id? att f?rs?ka uppgradera till n?gon version av version 7. Och att g?ra nya sajter blir f?r dyrt eller tar f?r mycket tid just nu. Jag m?ste p? n?got s?tt l?sa detta i existerande kod.

S? jag beh?ver lite kodningshj?lp p? 6.01.19 p? detta utm?rkta supportforum med v?nliga sj?lar som kan PHP och kanske har erfa av safemode-problematik!

Skickar med tv? olika zippar med 2 filer var, som jag tror ?r relevanta.

Det ?r s?kert j?ttel?tt att fixa f?r den som f?rst?r och begriper, och det ?r s?kert samma fel i b?da sajterna.
 
Homdax
Vi har ju n?t ?rende p? den engelska site som liknade detta. Har du s?kt h?r eller d?r p? "safemode"? Tror vi ber?rde det (?ven h?r) f?r max 14 dagar sedan.
 
Homdax

Look for the line in these files photogallery.php, showphoto.php, administration/photoalbums.php and administration/photos.php


define("SAFEMODE", @ini_get("safe_mode") ? true : false);

Replace it with:

define("SAFEMODE", true);

Redigerat av Falk den november 25 2010 16:33:23
 
etxgmg
Detta l?ste problemet (med den ena sajten, ska prova med den andra sen.)

Du ?r en ?ngel Homdax !!!!
 
Homdax
N?, mina polare p? PHP-Fusion Crew ?r. Men tack! Wink
 
etxgmg
Du ?r en ?ngel iaf, s? det s?!

Fast det verkar vara n?gon mer fil som beh?ver fixifieras lite ocks?, bildkommentarerna ?r borta, ska kolla sj?lv f?rst ...

EDIT: Nej, inte kommentarer, utan beskrivningen av varje bild ?r puts v?ck!
Redigerat av etxgmg den november 26 2010 10:02:24
 
Homdax
hmm, men f?ltet finns kvar i databasen?
Finns f?ltanropet kvar i kod?
 
etxgmg
db ok, ska kolla f?ltanropet...

jag lutar nu mer ?t att anv?ndarna har fel. Och att allt ?r ok nu, jag forts?tter kolla

Vi kan st?nga tr?den, tack f?r all hj?lp.
 
etxgmg
Vill bara l?gga till att f?r version 7 m?ste man ocks? g?ra samma f?r?ndring i administration/submissions.php

Allts?,

Look in all these files
- photogallery.php
- showphoto.php
- administration/photoalbums.php
- administration/photos.php
- administration/submissions.php

for the line:

Kod Källa  

define("SAFEMODE", @ini_get("safe_mode") ? true : false);


and replace it with:

Kod Källa  

define("SAFEMODE", true);
 
Gå direkt till forum: